Incompatible ETS2 & ATS Versions

SCS has released version 1.50 for Euro Truck Simulator 2 & American Truck Simulator

We do not support these updates yet on TruckersMP, but fortunately it is possible to downgrade to 1.49!

For information on downgrading your game, please click here

Event Description

Meetup Time Sat, May 18, 2024 17:30
Location Klagenfurt am Wörthersee (Katohode)
Destination Munich (WGCC)
Main Language English
Communication https://discord.gg/8DFZzsp
Link https://rotransexpress.ro/

Event Information


Attending (23)

User
Sh0tBlow
1 week ago
User
mafti7.8
1 week ago
User
[RO] pAM
1 week ago
User
Alesson_
1 week ago
User
jimmybret889
1 week ago
User
robert_edy1
1 week ago
User
sebastianGogo
2 weeks ago
User
[C-S] karol_domag
3 weeks ago
User
denism2554
1 month ago
User
vladutzuuu1
1 month ago
User
Vallentin
1 month ago
User
OnFun
2 months ago
User
`SonicTMP~ [TR,UK,GER]
2 months ago
User
Elle_TMP
3 months ago
User
[C-S] Iris.
3 months ago
User
CLAUDIU0031
3 months ago
User
[MR] Extrim
4 months ago
User
Leon1010
4 months ago
User
Sasha716
4 months ago
User
Sebyyy_RTE
5 months ago
User
Arun_Kashyap
5 months ago
User
pitigoi30061995
5 months ago

Unsure (0)