Incompatible ETS2 & ATS Versions

SCS has released version 1.50 for Euro Truck Simulator 2 & American Truck Simulator

We do not support these updates yet on TruckersMP, but fortunately it is possible to downgrade to 1.49!

For information on downgrading your game, please click here

Event Description

Meetup Time Sun, Jun 30, 2024 12:00
Location Mannheim (City)
Destination Other (Other)
Main Language English
Communication https://discord.gg/XkuvtTRzh9

Event Information

Event Organizer

Social


Attending (13)

User
ACC 950 Fei Lang
4 hours ago
User
_ChenChen__
3 weeks ago
User
SIAO
1 month ago
User
andywang1180
1 month ago
User
TW-BR948755
1 month ago
User
SRX_Cheng
1 month ago
User
User_4964566
1 month ago
User
LOCK XIAO
1 month ago
User
kate76543264
1 month ago
User
White tea latte
1 month ago
User
新手玩家
1 month ago
User
Wang wei
1 month ago
User
A-Liang
1 month ago

Unsure (4)

User
junyao
1 month ago
User
уσуσ
1 month ago
User
YaBa_1599
1 month ago
User
Fenggou
1 month ago