Incompatible ETS2 & ATS Versions

SCS has released version 1.50 for Euro Truck Simulator 2 & American Truck Simulator

We do not support these updates yet on TruckersMP, but fortunately it is possible to downgrade to 1.49!

For information on downgrading your game, please click here

Event Description

Meetup Time Wed, May 15, 2024 16:30
Location Lublin (LKW)
Destination Bratislava (TREE-ET)
Main Language English
Communication http://discord.himalayanlogistics.com

DLCs Requirements


Event Information


Attending (6)

User
SandMaN_CZ
1 week ago
User
Capt_Tom
1 week ago
User
Vurb
1 week ago
User
super37s
2 weeks ago
User
ReacherK
2 weeks ago

Unsure (4)

User
MenSpowd Gaming
1 week ago
User
BEAST GAMING STUDIO
1 week ago
User
[RO] pAM
1 week ago
User
Edawz33
1 week ago