Unsupported ATS & ETS2 version

SCS have released version 1.41 for American Truck Simulator and Euro Truck Simulator 2.

TruckersMP is currently NOT compatible with these updates. In order to play TruckersMP, you will need to downgrade your game to the temporary_1_40 branch.

Check out this article for information on how to downgrade your game.

Event Description

Location Prague (Quarry)
Destination Strasbourg (Quarry)
Main Language English
Communication https://discord.gg/eNnK9eQ
Link https://sparkvtc.com/

Event Information


Attending (43)

User
ispartaliAras
1 month ago
User
GameMa24
1 month ago
User
Miguel-Laguna[COL]
1 month ago
User
Twitchpukki
1 month ago
User
Phoenix142343
1 month ago
User
Robin TV
1 month ago
User
Sensib1ePanda
1 month ago
User
gestyaq
1 month ago
User
ruoskaa123
1 month ago
User
bloodline0012
1 month ago
User
stefanking891
1 month ago
User
Jayo
1 month ago
User
EazyCk3
1 month ago
User
Mr. hulk
1 month ago
User
_mj7
1 month ago
User
Tuomaala
1 month ago
User
F3sti
1 month ago
User
[USA] RailfanKaleb65
1 month ago
User
iiCloud
1 month ago
User
NFBL
1 month ago
User
//451
1 month ago
User
Galitianul
1 month ago
User
 Dallas
1 month ago
User
SRG [ UK ]
1 month ago
User
Vincent1291
1 month ago
User
[TPH] John
1 month ago
User
Ibiπsεriκ
1 month ago
User
BHtrucker
1 month ago
User
FR2005
1 month ago
User
ADEM.KERİM
1 month ago
User
Andrei07.Photo
1 month ago
User
/:\BlackSheep/:\
1 month ago
User
Axinte Anubis
1 month ago
User
/:\Adrián84/:\
1 month ago
User
Stefan93[NST]
1 month ago
User
unnebun1
1 month ago
User
Mosu
1 month ago
User
Ștremeleag
1 month ago
User
Bobita Carciumaru
1 month ago
User
Chrisxxs
1 month ago
User
tropicaltrucker
1 month ago
User
Adyox
1 month ago
User
N0fear92
1 month ago

Unsure (9)

User
Fragged-BE-
1 month ago
User
Angstman07
1 month ago
User
diego!
1 month ago
User
_Liongamer_
1 month ago
User
OtherGuy
1 month ago
User
PinkyTv
1 month ago
User
User_4360134
1 month ago
User
AABattery
1 month ago