Unsupported ATS & ETS2 version

SCS have released version 1.41 for American Truck Simulator and Euro Truck Simulator 2.

TruckersMP is currently NOT compatible with these updates. In order to play TruckersMP, you will need to downgrade your game to the temporary_1_40 branch.

Check out this article for information on how to downgrade your game.


Attending (26)

User
Kakeshi
3 days ago
User
marcostefano4
3 days ago
User
GrosNounours
3 days ago
User
SAMUELGIM
3 days ago
User
[GER] MrC85
3 days ago
User
Landyboy1231
3 days ago
User
[GER] Kev Hapunkt
4 days ago
User
benjidusal_ytb
4 days ago
User
[GER]Patrox
4 days ago
User
DaSchu
4 days ago
User
xXThorXx
4 days ago
User
Stephan mit Ph
4 days ago
User
MichaelCabry
4 days ago
User
Dancing29
4 days ago
User
GeminiBFE
4 days ago
User
aholeninja420
4 days ago
User
bryan2003
4 days ago
User
louloudu89
5 days ago
User
nino33710
1 week ago
User
Gianlu_A350
1 week ago
User
/:\ FelixZ1X /:\
1 week ago
User
Matt_On_Road
2 weeks ago
User
VeDoxe
2 weeks ago
User
THE SANCTIONER
2 weeks ago
User
IonRsnk
2 weeks ago
User
OCSC Antho
1 month ago

Unsure (1)

User
Stuhlprobe I REC
4 days ago