Incompatible ATS & ETS2 version

American Truck Simulator and Euro Truck Simulator 2 were just updated to version 1.44!
We do not support this update yet, but fortunately it is possible to downgrade to 1.43.

For information on downgrading your game, please click here

Event Description

Location Reykjavík (NHC)
Destination Dublin (LKW)
Main Language German

DLCs Requirements


Event Information

Event Organizer

Social


VTCs Attending (1)

Attending (10)

User
[IL] LeitplankenTobi
4 months ago
User
Blackcat1990
4 months ago
User
Habelse
4 months ago
User
Pierromato
4 months ago
User
[VTC] Wurmi
4 months ago
User
Der Falke ( GER)
4 months ago
User
[GER] steve213110
5 months ago
User
Patti[GER]
5 months ago
User
Marco-WhiteWolf
5 months ago
User
Cartman911
5 months ago

Unsure (3)

User
AlphaDragon9696[GER]
4 months ago
User
[REX] Alex
4 months ago