Incompatible ETS2 & ATS Versions

SCS has released version 1.50 for Euro Truck Simulator 2 & American Truck Simulator

We do not support these updates yet on TruckersMP, but fortunately it is possible to downgrade to 1.49!

For information on downgrading your game, please click here

Event Description

Meetup Time Thu, Jun 13, 2024 17:30
Location Liepāja (Rosmark)
Destination Olsztyn (TradeAux)
Main Language English

DLCs Requirements


Event Information


VTCs Attending (1)

Attending (8)

User
EricWP11
2 days ago
User
Stefan22
5 days ago
User
BARN3S
6 days ago
User
melongs
6 days ago
User
hjvg
1 week ago
User
R1ch1e
2 weeks ago
User
DeathMetalSir
3 weeks ago
User
mascotte149
1 month ago

Unsure (0)