KızılSancak VTC


Doğru Söz Yemin Gerektirmez.

TruckersMP Supports 1.45!

The latest versions of both ATS and ETS2 are fully supported on TruckersMP.

ProMods Europe and ProMods Canada are also fully supported.

Enjoy the update, and we hope to see you out on the road!