The Flourescent Yellow Truckers


Innovate, Inspire, Achieve

Unsupported ATS & ETS2 version

SCS have released version 1.41 for American Truck Simulator and Euro Truck Simulator 2.

TruckersMP is currently NOT compatible with these updates. In order to play TruckersMP, you will need to downgrade your game to the temporary_1_40 branch.

Check out this article for information on how to downgrade your game.

Information


Tag: TFYT
Language: English
Created: 27 Nov 2020 05:02 UTC
Supported Games
Euro Truck Simulator 2
American Truck Simulator
Owner: P h o e n i x
Members: 2
Recruitment: Open

Latest VTC Posts

There are currently no posts

Rules

Social

Requirements

There's a few requirements you should meet before applying to the VTC:

  • You must be in the Discord server before applying. - This is important so we can give you the appropriate role(s). There is no requirement to talk in a VC, but we do have a no mic channel for anyone who wants to still take part in conversation.
  • You must own a legitimate copy of ETS2/ATS.
  • You must not have more than 3 bans in the last year. (Active bans, it won't be possible to join the VTC on TruckersMP if you do not meet this requirement).
  • Your account must be activated on TruckersMP. How to activate your account: https://truckersmp.com/knowledge-base/article/298
  • You should use Trucksbook to track your jobs for the VTC - There is no activity requirement.

Members

P h o e n i x
P h o e n i x
Founder
Thunder!
Thunder!
Manager
View more