Transport General International


[TGI]

Incompatible ATS & ETS2 version

American Truck Simulator and Euro Truck Simulator 2 were just updated to version 1.44!
We do not support this update yet, but fortunately it is possible to downgrade to 1.43.

For information on downgrading your game, please click here

Information


Tag: [TGI]
Language: French
Created: 11 Jun 2021 20:57 UTC
Supported Games
Euro Truck Simulator 2
American Truck Simulator
Owner: Loupiotte
Members: 26
Recruitment: Open

Latest VTC Posts

There are currently no posts

Rules

Events We Are Attending

VTCAA | Monthly Convoy | Public #14

VTCAA | Monthly Convoy | Public #14

20 May 18:30 UTC

ATS

Convoy

To be determined

32 2 2

KizilSancak VTC 2nd Years Convoy

KizilSancak VTC 2nd Years Convoy

22 May 18:30 UTC

ETS2

Convoy

Event Server

172 7 34

View more

CONTACT US

Want to know more information or have a question?

By Website

Requirements

Members public