Zen Logistics


Just Hauling

Incompatible ATS & ETS2 version

American Truck Simulator and Euro Truck Simulator 2 were just updated to version 1.44!
We do not support this update yet, but fortunately it is possible to downgrade to 1.43.

For information on downgrading your game, please click here

Information


Tag: ZENL
Language: English
Created: 10 Nov 2021 00:54 UTC
Supported Game
Euro Truck Simulator 2
Owner: Latin-Foxy [Furry-ARG]
Members: 2
Recruitment: Open

Latest VTC Posts

There are currently no posts

Rules

CONTACT US

Want to know more information or have a question?

By Email

Social

Requirements

Be mature enough to understand the rules and play without generating drama nor problems. The VTC owners reserve the right to decline an application, but we won't deny one without a real reason.

No age, country, time zone, sex, experience nor mods limitations.

Members public

ZeraMalkav
ZeraMalkav
gon-daikyōjō
View more