The quick delivery Logistics


We got you covered.

Incompatible ATS & ETS2 version

American Truck Simulator and Euro Truck Simulator 2 were just updated to version 1.44!
We do not support this update yet, but fortunately it is possible to downgrade to 1.43.

For information on downgrading your game, please click here

Information


Tag: 53194
Language: English
Created: 01 Mar 19:17 UTC
Supported Games
Euro Truck Simulator 2
American Truck Simulator
Owner: mimitoo
Members: 2
Recruitment: Open

Latest VTC Posts

Event will be delayed!

Information about the upcoming event.

  |   24 Apr 19:30 UTC   |   kriseqk13

Rules

Events We Are Attending

ProMods Community Convoy

ProMods Community Convoy

11 Jun 16:00 UTC

ETS2

Convoy

To be determined

276 62 50

View more

Requirements

Inappropriate Content; changed by TMP Staff