Vangard VTC


Be a part of the Journey!

Incompatible ETS2 & ATS Versions

SCS has released version 1.50 for Euro Truck Simulator 2 & American Truck Simulator

We do not support these updates yet on TruckersMP, but fortunately it is possible to downgrade to 1.49!

For information on downgrading your game, please click here

Information


Tag: VANGARD
Language: English
Created: 29 Apr 2023 12:35 UTC
Supported Games
Euro Truck Simulator 2
American Truck Simulator
DLCs Required: 0
Owner: Merlin65
Members: 3
Recruitment: Open

Latest VTC Posts

Are you an Owner Operator driving alone?

We offer Tag Along sessions for other non virtual trucking company affiliated drivers, to join with others for short or long delivery jobs to enhance your gameplay.

  |   24 May 2023 12:00 UTC   |   Merlin65

Rules

CONTACT US

Want to know more information or have a question?

By Website

Requirements

  • You must behave in a mature manner when driving with or representing us.
  • No active or recent bans allowed, (Most recent ban no sooner than 6 months ago)
  • Have an established legal account at all the usual providers
  • Must speak good English
  • Be prepared to mentor fellow gamers with any issues they may have

DLC Requirements

No DLCs Required

Members

Merlin65
Merlin65
Owner
atkinsonchris
atkinsonchris
Dispatcher
Mudflap3467
Mudflap3467
Approved Driver
View more