Hogwarts Express VTC


"Hogwarts Express: The Magical World of Trucks!"

Incompatible ETS2 & ATS Versions

SCS has released version 1.50 for Euro Truck Simulator 2 & American Truck Simulator

We do not support these updates yet on TruckersMP, but fortunately it is possible to downgrade to 1.49!

For information on downgrading your game, please click here

Information


Tag: HEVTC
Language: Turkish
Created: 01 Oct 2023 14:39 UTC
Supported Game
Euro Truck Simulator 2
DLCs Required: 0
Owner: KeremKhan
Members: 12
Recruitment: Open

Our Events

HOGWARTS EXPRESS VTC OPENING CONVOY

HOGWARTS EXPRESS VTC OPENING CONVOY

Mon, Jul 8, 2024 18:00

ETS2

Convoy

Event Server

166 6 52

View more

Latest VTC Posts

Hogwarts Express VTC Painting Job

We are proud to announce our Hogwarts Express paint job.

  |   04 Oct 2023 11:38 UTC   |   KeremKhan

Rules

Events We Are Attending

Yorkshire Haulage May Convoy

Yorkshire Haulage May Convoy

Tue, May 28, 2024 18:00

ETS2

Convoy

Simulation 2

23 1 15

Fate VTC - 1st Anniversary

Fate VTC - 1st Anniversary

Wed, May 29, 2024 19:00

ETS2

Convoy

Event Server

179 13 48

View more

CONTACT US

Want to know more information or have a question?

By Website

Requirements

Requirements:

  1. Drivers over +17 years old.
  2. Drivers with over +100 hours in Euro truck simulator 2.
  3. Drivers with at least 2 active bans in TruckersMP and no bans in the last 3 months.
  4. There is no DLC requirement.
  5. Drivers who can adapt to the team with respect and love.

DLC Requirements

No DLCs Required

Members

KeremKhan
KeremKhan
Head of Hogwarts
I'm Espera
I'm Espera
Caretaker of Hogwarts
ESESLIYIZ2626
ESESLIYIZ2626
Gryffindor
Serhan Recepce
Serhan Recepce
Hufflepuff
Ilkan.
Ilkan.
Hufflepuff
latocan66
latocan66
Hufflepuff
View more