Piha Transporti


Quality without question.

1.41 for both games is now supported!

We are happy to announce support for Euro Truck Simulator 2 and American Truck Simulator 1.41!

Information


Tag: PIHA-TRANS
Language: English
Created: 16 Dec 2019 20:22 UTC
Supported Game
Euro Truck Simulator 2
Owner: R3Z4N4CHR
Members: 1
Recruitment: Closed

Latest VTC Posts

There are currently no posts

Rules

CONTACT US

Want to know more information or have a question?

By Email

Requirements

Requirements 1 +30 hours in game 2 NO active bans 3 **You need to be active on convoys **(you have to come) 4 Teamspeak / Discord 5 At least +15 years-old

Members