ΛNGΞLΞS GROUP


AMOR POR LA RUTA

Incompatible ETS2 & ATS Versions

SCS has released version 1.50 for Euro Truck Simulator 2 & American Truck Simulator

We do not support these updates yet on TruckersMP, but fortunately it is possible to downgrade to 1.49!

For information on downgrading your game, please click here

Information


Tag: ΛNGΞLΞS G
Language: Spanish
Created: 15 Apr 2022 22:08 UTC
Supported Game
Euro Truck Simulator 2
DLCs Required: 0
Owner: tonymontana311996
Members: 3
Recruitment: Open

Latest VTC Posts

There are currently no posts

Rules

CONTACT US

Want to know more information or have a question?

By Website

Requirements

los requisitos sera lo mismo por el momento si comom valla avanzando se ira llenado este elemento

DLC Requirements

No DLCs Required

Members

tonymontana311996
tonymontana311996
PЯOPIΞTΛЯIO
MΛDMΛX
MΛDMΛX
GΞЯΞNTΞ
ΞmisicK420
ΞmisicK420
GΞЯΞNTΞ
View more