Steam API issues

Steam API is currently reporting outdated information to our servers, therefore some users can not register in TruckersMP. As the issue is out of our reach, unfortunately, there is nothing we can do to resolve the problem.

If you experience that, please try again later. Apologies for the inconvenience.

It's time to downgrade!

TruckersMP does not support the latest game version of Euro Truck Simulator 2 or American Truck Simulator yet.
Check out the following guide on how to downgrade so you can keep playing on multiplayer:
How to downgrade

Unsupported Game Version

Before creating a support ticket about your game version not being supported in TruckersMP

SCS released an update for ATS + ETS 2. We do not support the latest version of American Truck Simulator or Euro Truck Simulator 2 yet. You need to wait until we release a game update in order to play the newest version of ATS in our MP.

Downgrading to an older version is possible. More information can be found here