It's time to downgrade!

TruckersMP doesn't support the latest game version of American Truck Simulator yet.
Check out the following guide on how to downgrade so you can keep playing on multiplayer: How to downgrade

Unsupported Game Version

Before creating a support ticket about your game version not being supported in TruckersMP

SCS released an update for ATS. We do not support the latest version of American Truck Simulator yet. You need to wait until we release a game update in order to play the newest version of ATS in our MP.

Downgrading to an older version is possible. More information can be found here

Steam Authentication


In order to create Support ticket or view the existing ones, authenticate via your Steam account by clicking the button below