Global Express


Light or heavy, we do it.

Incompatible ETS2 & ATS Versions

SCS has released version 1.50 for Euro Truck Simulator 2 & American Truck Simulator

We do not support these updates yet on TruckersMP, but fortunately it is possible to downgrade to 1.49!

For information on downgrading your game, please click here

Information


Tag: GLEX
Language: English
Created: 16 Dec 2020 04:09 UTC
Supported Game
Euro Truck Simulator 2
DLCs Required: 0
Owner: Bombero18132
Members: 2
Recruitment: Open
favho_xd
favho_xd
Founder