Wolves™


We Go Further To Bring You Closer

Unsupported ATS & ETS2 version

SCS have released version 1.41 for American Truck Simulator and Euro Truck Simulator 2.

TruckersMP is currently NOT compatible with these updates. In order to play TruckersMP, you will need to downgrade your game to the temporary_1_40 branch.

Check out this article for information on how to downgrade your game.

Information


Tag: Wolves™
Language: English
Created: 21 Oct 2019 05:43 UTC
Supported Games
Euro Truck Simulator 2
American Truck Simulator
Owner: RequieB
Members: 71
Recruitment: Open

Our Events

Wolves™ ATS August Public Convoy

Wolves™ ATS August Public Convoy

14 Aug 18:00 UTC

ATS

Convoy

Event Server

53 3

Wolves™ ETS August Public Convoy

Wolves™ ETS August Public Convoy

28 Aug 18:00 UTC

ETS2

Convoy

To be determined

53 2

View more

Our Gallery

  • darkblurbg
  • darkblurbg
  • darkblurbg
  • darkblurbg
View more

Latest VTC Posts

👋 | Welcome to the Wolves™ VTC

Welcome to the Wolves™ VTC

  |   24 Feb 21:25 UTC   |   RequieB

📋 | Application Requirements

Explanation for the Requirements

  |   18 Mar 09:16 UTC   |   Lycan.

🗃️ | Memorable Photos of July

During the month of July, several of our members sent us some breathtaking photos. Here are just some of them!

23 Jul 00:19 UTC   |   Kenny246

🗃️ | Wolves™ Official Paint Job

Haven't you seen our new paint job?

20 Jul 11:36 UTC   |   Kenny246

🚚 | Summary of Wolves July Public Convoy

Here you can find a recap of Wolves July Public Convoy...

19 Jul 21:01 UTC   |   Kenny246

Rules

CONTACT US

Want to know more information or have a question?

By Website

Requirements

1

Members

RequieB
RequieB
Founder
Next7
Next7
CEO
Lycan.
Lycan.
COO
AdaBey
AdaBey
General Manager
Kenny246
Kenny246
General Manager
_phillip_
_phillip_
General Manager
View more