Unsupported ETS2 & ATS version!

1.42 has just been released for Euro Truck Simulator 2 and American Truck Simulator.

TruckersMP is currently NOT compatible with these updates. In order to play TruckersMP, you will need to downgrade your game to the temporary_1_41 branch.

Check out this article for more information on how to downgrade your game.

Scout Car Survey!

Interested in having a say on the future design of the Scout car? Well check out the following survey to let your ideas be known!

You can find the survey here.

We have more articles in English. Switch back to English?